The Cache: Technology Expert's Forum
 
*
Welcome, Guest. Please login or register. September 22, 2019, 06:08:32 PM

Login with username, password and session length


Pages: [1]
  Print  
Author Topic: Problem installing SSH2 functions in PHP - nn help!  (Read 2378 times)
perkiset
Olde World Hacker
Administrator
Lifer
*****
Offline Offline

Posts: 10096



View Profile
« on: October 09, 2007, 12:57:55 PM »

Hello all -

I am endeavoring to install the ssh2 lib for PHP on a new box.
I have installed OpenSSL-0.9.8e, no complaints or worries.
I have installed libssh2-0.17, no complaints or problems.

I am now trying to install the ssh2 functions themself. I have done both of these and get the same result:

pear install ssh2

and

(download the ssh2-0.10.tar.gz)
phpize
./configure --with-ssh2 --with-php-config=/usr/local/bin/php
make

In both cases, when the MAKE is running I get this set of warnings and finally the error shortly after it starts:
Code:
/usr/local/install/ssh2-0.10/ssh2.c:1097: warning: passing argument 4 of 'add_assoc_stringl_ex' discards qualifiers from pointer target type
/usr/local/install/ssh2-0.10/ssh2.c:1098: warning: passing argument 4 of 'add_assoc_stringl_ex' discards qualifiers from pointer target type
/usr/local/install/ssh2-0.10/ssh2.c:1106: warning: initialization discards qualifiers from pointer target type
/usr/local/install/ssh2-0.10/ssh2.c:1107: warning: passing argument 2 of '_zend_hash_add_or_update' discards qualifiers from pointer target type
make: *** [ssh2.lo] Error 1

I've done a bit of research and found 2 ".diff" files that contains patches for it (supposedly) but I do not know how to use or apply them.
This blog: http://kevin.vanzonneveld.net/techblog/article/make_ssh_connections_with_php/ describes the patches - it's the only thing I've found that references these two patches (perhaps I'm searching wrong).

Can someone point me in the right direction about how to apply these patches, or if someone has another suggestion, I am rather in a bind.

TIA,
/p

Logged

It is now believed, that after having lived in one compound with 3 wives and never leaving the house for 5 years, Bin Laden called the U.S. Navy Seals himself.
jairez
Expert
****
Offline Offline

Posts: 164


JTFC


View Profile
« Reply #1 on: October 09, 2007, 02:31:34 PM »

Dude ... YOU'RE having PHP problems? 

OK, I know bad ..... that's bad.

Sorry ... when I get bound up like this it's straight back to apt-get or dselect for me.  If that doesn't work, I'd post on a board somewhere .... hey, wait a minute?!?!?!?

q:  do you have permissions or ports that should be opened up?  Tokens or cookies?  Do you have the opportunity for a package manager of some kind?

Sorry, man.  I'd piss on a spark plug if I thought it would help, but I'm at a loss.

Didn't want you to feel all alone :~}

   /ja

Logged

Spontaneity has it's time and place.  [Sluggo, 1990-ish]
perkiset
Olde World Hacker
Administrator
Lifer
*****
Offline Offline

Posts: 10096



View Profile
« Reply #2 on: October 09, 2007, 03:17:45 PM »

 ROFLMAO

Well in truth, this is more of a Linux/Compiler/Shell/PHP Extensions sort of problem than PHP proper, but indeed, I am stumped.

I've done this a bazillion times with other extensions, but never had as much of a stopper and as little info on the 'net before... it seems that there is an identified bug by some PECL folks in August, but it doesn't look like many folks have come up against it yet.

I'm thinking of seeing if I can get a lower version number and make it work, although that's never a really good idea...
Logged

It is now believed, that after having lived in one compound with 3 wives and never leaving the house for 5 years, Bin Laden called the U.S. Navy Seals himself.
Pages: [1]
  Print  
 
Jump to:  

Perkiset's Place Home   Best of The Cache   phpMyIDE: MySQL Stored Procedures, Functions & Triggers
Politics @ Perkiset's   Pinkhat's Perspective   
cache
mart
coder
programmers
ajax
php
javascript
Powered by MySQL Powered by PHP Powered by SMF 1.1.2 | SMF © 2006-2007, Simple Machines LLC
Seo4Smf v0.2 © Webmaster's Talks


Valid XHTML 1.0! Valid CSS!